Chat with us, powered by LiveChat

Internet Explorer Browser Support

Lorry Route unsupported browsers

Lorry Route Web Application and Internet Explorer 10 and Below

Lorry Route web application does not support Internet Explorer 10 and below.

If you are using Internet Explorer 10 and below please upgrade your browser to Microsoft Edge.

Since December 2016, Microsoft no longer provides security updates or technical support for old versions of Internet Explorer. Therefore Microsoft recommends you update your browser to ensure you get regular security updates and the best user experience.

For more details please see Microsoft support page

Alternative Browsers

You can access Lorry Route web application from the following web browsers

  • Chrome
  • Firefox
  • Safari
  • Microsoft Edge